EIGRP Stub Router Concept

Stub-router, when we listen to this we immediately get the feeling like some LSAs are filtered, some summary route, etc. But in the EIGRP Stub router concept is different; here stub router concept came into the picture to avoid EIGRP Stuck In Active (SIA). The Router which is configured as a stub router will inform it’s neighbor that I am the last router of the network, I do not have any neighbor connected with me.

Little confusing? Okay, let me try to explain it with some topology.

1

Now, what will be the output in the test and control router if we do not configure Stub router as a stub?

It will receive all the routes, let us verify.

Configuration:

Control_Router#sh run | s eigrp
router eigrp 50
network 0.0.0.0
no auto-summary

Stub_Router#sh run | s eigrp
router eigrp 50
network 10.10.10.2 0.0.0.0
network 10.10.10.6 0.0.0.0
no auto-summary

Test_Router#sh run | s eigrp
router eigrp 50
network 0.0.0.0
no auto-summary

Output:

Control Router

2

Stub Router

3

Test Router

4

Now, we can see that we are learning all routes in all router.

Now, let us see what happened if we introduce stub command in the stub router. Remember here we are configuring only stub command means default stub which will publish only connected and summary.

Configuration:

Stub_Router#sh run | s eigrp
router eigrp 50
network 10.10.10.2 0.0.0.0
network 10.10.10.6 0.0.0.0
no auto-summary
eigrp stub connected summary

Output:

Control Office:

5

So, you can see that we are not learning the loopbacks of Test Router anymore and will be same with Test Router, let’s verify.

Test Router:

6

So we can see the expected result. Now let us see what is the routing table of the Stub Router.

Stub Router:

7

So, this is what we will achieve by default stub configuration in eigrp.

Let me explain receive only.

Receive only means it will only receive the routes but will not send any routing updates. I have now configured 3 new Loopbacks in the Stub Router and let us verify whether we can see those routes in other routers or not.

Configuration:

Stub_Router#sh ip int brief | e unass

Interface                  IP-Address      OK? Method Status                Protocol

Serial1/0                  10.10.10.2      YES manual up                    up
Serial1/1                  10.10.10.6      YES manual up                    up
Loopback1                  30.20.10.1      YES manual up                    up
Loopback2                  30.20.20.1      YES manual up                    up
Loopback3                  30.20.30.1      YES manual up                    up

Stub_Router#sh run | s eigrp
router eigrp 50
network 10.10.10.2 0.0.0.0
network 10.10.10.6 0.0.0.0
network 30.20.10.0 0.0.0.255
network 30.20.20.0 0.0.0.255
network 30.20.30.0 0.0.0.255
no auto-summary

Output:

Control Office:

8

Test Router:

9

So, we can see we are receiving all the routes in both the router. Now, what if we configure the stub router as receive only, we will not see test router and stub router routes in Control Office Router and vice versa. Let us verify.

Configuration:

Stub_Router#sh run | s eigrp
router eigrp 50
network 10.10.10.2 0.0.0.0
network 10.10.10.6 0.0.0.0
network 30.20.10.0 0.0.0.255
network 30.20.20.0 0.0.0.255
network 30.20.30.0 0.0.0.255
no auto-summary
eigrp stub receive-only

Output:

Control Office:

10.png

You can even see we are not receiving the connected routes or received routes of the stub router, will see the same in test router.

Test Router:

11

Let us verify whether we received the routes in Stub Router.

Stub Router:

12

I hope, I have explained the EIGRP Stub Router concept; appreciate your question and criticism.

Architect/Consultant in IT/Telecom/Networking Support Industry with over 13+ years of Experience. Mainly working with Cisco Products other than Cisco worked with VMware NSX/Juniper/Riverbed/Meraki & Citrix Products, and worked with various clients like PSU Banks, Petroleum Corporations, different government sector clients, BPO Sector, Telecom NOC and ISP. Global Certifications: VMware vSphere Foundation 6 CCNA Routing & Switching CCNP Routing & Switching ITIL V3 Foundation RTSA-W RTSS-W RSA RTSA-NPM RTSS-NPM Aspiring Certifications: VCP-NV

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.